Le problème

Un écran noir au lieu de l'écran de login. Xorg.0.log contenait l'erreur suivante :

[   110.203] (EE) NVIDIA(0): Failed to get supported display device(s)
[   110.229] (EE) NVIDIA(0): No display devices found for this X screen.
[   110.317] (EE) Screen(s) found, but none have a usable configuration.

Le module et les bibliothèques sont pourtant anciennes, mais quelque chose dans le noyau doit avoir changé.

Une solution

Réouvrir une session graphique

C'est le moyen le plus simple d'avoir une connexion (nmcli con up échoue chez moi). Pour cela, afficher le tty 2 avec "ctrl+alt+f2", puis se logger en root. Puis :

rm /etc/X11/xorg.conf
modprobe -rv nvidia
modprobe nouveau
killall gdm-binary

Réinstaller le pilote en version 285

Ouvrir sa session graphique.

yum -y remove *nvidia*
wget ftp://fr2.rpmfind.net/linux/rpmfusion/nonfree/fedora/releases/16/Everything/i386/os/akmod-nvidia-285.05.09-1.fc16.4.i686.rpm
wget ftp://fr2.rpmfind.net/linux/rpmfusion/nonfree/fedora/releases/16/Everything/i386/os/xorg-x11-drv-nvidia-285.05.09-1.fc16.i686.rpm
wget ftp://fr2.rpmfind.net/linux/rpmfusion/nonfree/fedora/releases/16/Everything/i386/os/xorg-x11-drv-nvidia-libs-285.05.09-1.fc16.i686.rpm
yum -y localinstall akmod-nvidia-285.05.09-1.fc16.4.i686.rpm xorg-x11-drv-nvidia-285.05.09-1.fc16.i686.rpm xorg-x11-drv-nvidia-libs-285.05.09-1.fc16.i686.rpm

Protéger le pilote des prochaines mises à jour

Ajouter exclude=*nvidia* à /etc/yum.conf pour éviter que les modules 290 n'écrasent celui-ci. Un petit reboot et voilà....%% Le plus étrange, c'est que nvidia-xconfig --query-gpu-info me rapporte bien DFP-0...